Hi Everybody! - Page 2 - VTXOA
 6Likes
Reply
 
LinkBack Thread Tools
post #11 of 15 (permalink) Old 08-09-2019, 01:50 PM
Pope "papa" of the VTXOA
 
Chicago-Spike's Avatar
 
Join Date: Nov 2003
Location: St Charles, IL.
Posts: 63,354
If they rattle, then the bushings are worn out. Contact Kuryakyn for parts to fix it as it should make no noise

AMA Life Member 721314
Chicago-Spike is offline  
Sponsored Links
Advertisement
 
post #12 of 15 (permalink) Old 08-09-2019, 01:54 PM
Pope "papa" of the VTXOA
 
Chicago-Spike's Avatar
 
Join Date: Nov 2003
Location: St Charles, IL.
Posts: 63,354
P/N Description UOM Price
9332 Pro-Series Butterfly Shaft Caps with Screws, Washers, Bearings, & Spring SET $17.99
ADD TO CART
https://www.kuryakyn.com/products/90...s-hypercharger

I believe those are the parts you need, call to and ask to be sure

AMA Life Member 721314
Chicago-Spike is offline  
post #13 of 15 (permalink) Old 08-09-2019, 09:08 PM Thread Starter
Junior Member
 
drperry's Avatar
 
Join Date: Aug 2019
Posts: 8
It's constantly opening and closing from 1/4 open... I probably have a vacuum leak going to the thing, lol. It felt solid when I tried wiggling by hand, but I'll look at i5 closer, thanks!

Sent from my SM-G965W using Tapatalk
drperry is offline  
 
post #14 of 15 (permalink) Old 08-10-2019, 11:07 AM
Pope "papa" of the VTXOA
 
Chicago-Spike's Avatar
 
Join Date: Nov 2003
Location: St Charles, IL.
Posts: 63,354
Check teh vacuum line that's hooked into the Hyper. If there is a check valve on that vacuum line, you have to remove it. It needs a solid line from the canister to the Hyper, no check valve or it won't work as it should. It should open and close with the throttle like on a old school funny car

AMA Life Member 721314
Chicago-Spike is offline  
post #15 of 15 (permalink) Old 08-10-2019, 12:44 PM Thread Starter
Junior Member
 
drperry's Avatar
 
Join Date: Aug 2019
Posts: 8
Quote:
Originally Posted by Chicago-Spike View Post
Check teh vacuum line that's hooked into the Hyper. If there is a check valve on that vacuum line, you have to remove it. It needs a solid line from the canister to the Hyper, no check valve or it won't work as it should. It should open and close with the throttle like on a old school funny car

Will double check it, thanks! For the most part it works, but at 30 - 40MPH in 3rd gear it flaps like crazy

Sent from my SM-G965W using Tapatalk

Last edited by drperry; 08-11-2019 at 07:56 AM.
drperry is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the VTXOA forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome