Rideon Works - VTXOA
 2Likes
  • 1 Post By JPT
  • 1 Post By chuck_VTX F
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 04-23-2019, 09:52 PM Thread Starter
JPT
Senior Member
 
JPT's Avatar
 
Join Date: Jun 2018
Location: Long Island, NY
Posts: 368
Garage
Rideon Works

So, on my way home from work today, I was going about 65 mph. I heard a loud pop (over the sound of my stereo). I wasn’t sure what it was, I wasn’t sure if something fell off the bike so I looked in the mirror and didn’t see anything.

To be safe, I pulled over and got off to check if anything was damaged. Turns out, I was losing air out of the rear tire. Within 5 minutes there was no air left in the tire. Had I not heard the loud pop, I wouldn’t have even known I had a blow out.

I called my Allstate motorclub and had it towed the 30 miles to my local shop.





While waiting for the tow truck, I Amazon primed a new bottle of Rideon for my next tire.

Honestly, I think my tire was at the end of its life, and I wasn’t paying attention. I had 7k miles on it, Shinko 777.
DrDolittle likes this.

2009 VTX1300R
JPT is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-24-2019, 08:20 AM
Senior Member
 
chuck_VTX F's Avatar
 
Join Date: Aug 2007
Location: RGV. Texas, Former N.E. Ohio
Posts: 8,458
Garage
glad all went well...




I get 17,000 miles from my Dunlop Elite's.
I average 7,000 miles per year.
DrDolittle likes this.



2005 VTX1800 F, type II, Silver Tribal, 86,000 Miles, Purchased Feb, 2005.
MTC clutch & springs.. K&N Air Filter. Garmin 2597 GPS.
chuck_VTX F is online now  
post #3 of 3 (permalink) Old 04-25-2019, 07:04 PM
Senior Member
 
Join Date: Mar 2013
Location: Louisville Ky
Posts: 612
My front tire went flat on the bottom in december because of valve stem leak. The ride on got between the rim and tire and wouldn't hold air. I took the tire off and had to sand tire and rim to get it off . I put the tire back on backwards as it had some wear on the left side . Handel's like a dream ! Never handled that good . I run Metzler front, Michelin rear . got a valve stem with nuts on it too. I didn't put ride on back in it . still thinking. Eo
Engineoops is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the VTXOA forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome