Turn Signals not working - VTXOA
 10Likes
Reply
 
LinkBack Thread Tools
post #1 of 13 (permalink) Old 04-26-2019, 06:02 PM Thread Starter
Senior Member
 
mightywarrior72's Avatar
 
Join Date: Apr 2010
Location: Long Beach, Ca.
Posts: 1,420
Turn Signals not working

'05 1300R
Turn signal switch doesn't work consistently. Sometimes it will initiate the signals to come on, sometimes not. The switch feels very spongy. When the bike is at speed they seem to work more consistently. Seems like when engine revs it raises the voltage and sends the signal through bad contacts.

Question:
I can clean the contacts with spray cleaner.
Is there a way to strengthen the spring action that makes the switch contacts?
Can I replace just the switch contacts, or do I need to replace the entire Turn, High beam, horn switch assembly?
The whole assembly is only about $95 but my wires are internally ran through the handlebars and it is difficult to replace the entire switch and wiring harness.

Any help would be appreciated.

Thanks

The earlier I get behind, the longer I will have to try and catch up.
It doesn't take me all day to get nothing done; I can get nothing done by break time.
mightywarrior72 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 04-26-2019, 06:17 PM
Senior Member
 
smurfy71's Avatar
 
Join Date: Aug 2018
Location: Ontario, Canada
Posts: 371
You can disassemble the switch and clean it. There is a thread in the How to Section I believe.


Sitting on my VTX making vroom vroom sounds.

https://www.hondashadow.net/forum/me...e71386-vtx.jpg

2006 Shadow Aero 750 (sold Oct 2018 )
2008 VTX1300T

smurfy71 is online now  
post #3 of 13 (permalink) Old 04-26-2019, 07:03 PM
Senior Member
 
DrDolittle's Avatar
 
Join Date: May 2017
Posts: 498
Garage
https://www.vtxoa.com/forums/73-how-...-cleaning.html

By Hans & F. It is a download.
Hans&Feet likes this.
DrDolittle is offline  
 
post #4 of 13 (permalink) Old 04-26-2019, 07:33 PM
Senior Member
 
chuck_VTX F's Avatar
 
Join Date: Aug 2007
Location: RGV. Texas, Former N.E. Ohio
Posts: 8,427
Garage
all the switches on a VTX are designed to be disassembled and cleaned..


we have been requesting everyone to clean all switches every 2 years...


No you can not purchase just a switch... or parts of a switch


it's the complete control handle assembly.. or NOTHING...


so clean them.. they can last almost forever.
DrDolittle likes this.



2005 VTX1800 F, type II, Silver Tribal, 86,000 Miles, Purchased Feb, 2005.
MTC clutch & springs.. K&N Air Filter. Garmin 2597 GPS.
chuck_VTX F is online now  
post #5 of 13 (permalink) Old 04-26-2019, 08:19 PM
Senior Member
 
henkvdb's Avatar
 
Join Date: Mar 2018
Location: Louisville CO
Posts: 113
'all switches'.





Chuck,
is my slow brain finally reading that it is not only the STARTER switch that needs cleaning, but the light/blinker/horn also?

2003 1800s, 88k miles
henkvdb is offline  
post #6 of 13 (permalink) Old 04-27-2019, 03:17 PM
Senior Member
 
leroys73's Avatar
 
Join Date: Feb 2010
Location: Dallas Area
Posts: 1,252
I have used electric contact spray on mine. But it did not last very long. It was worse if I let it sit for several days. At 100,000 miles I replaced my starter switch harness as a just in case procedure. 30,000 miles later I replaced my turn signal harness because the button broke while on an IBA ride.

Neither was difficult.
DrDolittle likes this.

My VTX as used on Race Tech site.I'm70 rode 07 Black Cherry VTX 1300R to 49 States+DC & 11 Provinces, 138,000mi+Yamaha RSV,37,000mi,both w/aux tank & Race Tech SuspensionIBA:Mile Eater Bronze &Silver,SS3000,3xSS2000,EclipseSS1000Gold, 19SS1000,6xBB1500,3TX1000,NPT 29/76; Lake Superior Circle Tour 15 to 20K per yr between the two MCs
leroys73 is offline  
post #7 of 13 (permalink) Old 04-27-2019, 04:54 PM Thread Starter
Senior Member
 
mightywarrior72's Avatar
 
Join Date: Apr 2010
Location: Long Beach, Ca.
Posts: 1,420
I disassembled and soaked in White Vinegar then Rubbing Alcohol. i let dry and reinstalled. Seems great. One question:
What parts do I lube and with what? Should I only grease the pivot fork?
Any input is appreciated.

Thanks

The earlier I get behind, the longer I will have to try and catch up.
It doesn't take me all day to get nothing done; I can get nothing done by break time.
mightywarrior72 is offline  
post #8 of 13 (permalink) Old 04-27-2019, 09:00 PM
Senior Member
 
Hans&Feet's Avatar
 
Join Date: Jun 2005
Location: Conyers/McDonough, GA
Posts: 9,918
Garage
If it moves grease it!
Grease the switch, it is a sliding arrangement.
Grease the mechanical so it will cancel better.

It had grease in it from the factory, it became dusty and dirty and no longer functioned as a lubricant.
Wheel bearing grease is what I used...
Attached Images
File Type: jpg TS back in housing.jpg (466.9 KB, 4 views)
File Type: jpg TS switch dirty1.jpg (489.9 KB, 4 views)
leroys73 and DrDolittle like this.

2005 1300c Red, Mustang seat, HK 2.5 straights. Leds for safety-front & back. 190,260 VTX miles

Last edited by Hans&Feet; 04-28-2019 at 12:07 PM. Reason: Before and after cleaning
Hans&Feet is offline  
post #9 of 13 (permalink) Old 04-27-2019, 11:23 PM Thread Starter
Senior Member
 
mightywarrior72's Avatar
 
Join Date: Apr 2010
Location: Long Beach, Ca.
Posts: 1,420
Thank you.
I have always valued your opinion.
Hans&Feet likes this.

The earlier I get behind, the longer I will have to try and catch up.
It doesn't take me all day to get nothing done; I can get nothing done by break time.
mightywarrior72 is offline  
post #10 of 13 (permalink) Old 04-28-2019, 11:04 AM
Senior Member
 
chuck_VTX F's Avatar
 
Join Date: Aug 2007
Location: RGV. Texas, Former N.E. Ohio
Posts: 8,427
Garage
Quote:
Originally Posted by henkvdb View Post
'all switches'.


Chuck,
is my slow brain finally reading that it is not only the STARTER switch that needs cleaning, but the light/blinker/horn also?

sorry for the delay.. YES, all switches...

nothing about "SLOW"..

I was branded "Retarded" in the 4th grade by 2 doctors..
I was just a SLOW starter...
leroys73 likes this.



2005 VTX1800 F, type II, Silver Tribal, 86,000 Miles, Purchased Feb, 2005.
MTC clutch & springs.. K&N Air Filter. Garmin 2597 GPS.

Last edited by chuck_VTX F; 04-28-2019 at 11:08 AM.
chuck_VTX F is online now  
Reply

Tags
switch , turn signals

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the VTXOA forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome