Honda VTX Forum banner

1 - 13 of 13 Posts

·
Old Goat
Joined
·
25,398 Posts
Discussion Starter #1
I have a relatively new Yuasa bat (3 months) and yuasa maintainer....had a green light as I prepared to go for a ride..but guilty conscience (dog was spayed and cone of shame) Kept me home ...I plugged back up per instructions took 2-days to get a green light ....opinions please...
 

·
Premium Member
Joined
·
7,152 Posts
I have a relatively new Yuasa bat (3 months) and yuasa maintainer....had a green light as I prepared to go for a ride..but guilty conscience (dog was spayed and cone of shame) Kept me home ...I plugged back up per instructions took 2-days to get a green light ....opinions please...
Good question. It's hard to say for certain without deep diving this, but it's important to know that many battery maintainers have a desulphation cycle to effectively refresh the battery. I have never seen this take 2 days though, but not necessarily outside the realm of possibility. How does the bike start? If it sits for a couple of days without the charger on it, does it flip over like nothing or does it drag and concern you that you may have a battery problem. The next step would be to get the battery load tested.
 
  • Like
Reactions: SUMDATX

·
Old Goat
Joined
·
25,398 Posts
Discussion Starter #3
Stays on maintainer...fires right up...Im not familar with the yuasa maintainer....usually have JR’s but last one crapped out on me.thought I would try something new.....I guess I could pose question to Yuasa ....but response is quicker here....thanks for reply
 
  • Like
Reactions: SUMDATX

·
Registered
Joined
·
11,945 Posts
Remove the battery connections, clean posts and cable lugs. Verify fuse on charging cable is good. Also the connector.
 

·
Registered
Joined
·
234 Posts
Stays on maintainer...fires right up...Im not familar with the yuasa maintainer....usually have JR’s but last one crapped out on me.thought I would try something new.....I guess I could pose question to Yuasa ....but response is quicker here....thanks for reply
Might be a good idea to contact them (Yuasa) anyway. Doesn't sound like a battery problem to me, although I did change from Yuasa batteries (which I have use for years) to this;
 

·
Registered
Joined
·
6,368 Posts
I've never had to wait TWO DAYS for green light! You have more patience than I do, and a stronger bladder too....sitting there that long was why you "plugged up"💩


Battery is good if you sat there that long I"m guessing.....
 
  • Like
Reactions: TennX

·
Registered
Joined
·
959 Posts
I second the fuse on the charger..found out (eventually) that there even was one...
 

·
Registered
Joined
·
234 Posts
Stays on maintainer...fires right up...Im not familar with the yuasa maintainer....usually have JR’s but last one crapped out on me.thought I would try something new.....I guess I could pose question to Yuasa ....but response is quicker here....thanks for reply
Hey TennX, did you every get to the bottom of that problem?
 

·
Old Goat
Joined
·
25,398 Posts
Discussion Starter #9
Hey TennX, did you every get to the bottom of that problem?
Everything checked out ok...battery is good....just gonna wait and see...cant ride at the moment anyway....I’m thinking yuasa maintainer is to blame...
 
  • Like
Reactions: SUMDATX and Harkon

·
Registered
Joined
·
11,945 Posts
I did change from Yuasa batteries (which I have use for years) to this;
DEKA - East Penn Manufacturing.
A unique battery post.. One of a kind.
I have gone through two, one went far, the other not so far. Back to Yuasa.
 

·
Registered
Joined
·
1,482 Posts
Phil,
Which Battery Tender do/did you have? Some models have a 10 year warranty and they are good to deal with a warranty claim. And maybe you already tossed it. I have quite a few Battery Tenders on different vehicles and for my bikes it is always YUASA battery, they have always had the longest life span.
 
  • Like
Reactions: SUMDATX

·
Premium Member
Joined
·
7,152 Posts
Everything checked out ok...battery is good....just gonna wait and see...cant ride at the moment anyway....I’m thinking yuasa maintainer is to blame...
Every brand has been known to have failures so it's a distinct possibility.

Maybe give Hans' possibility a quick try. It's free and easy. If that checks out, I think you likely found the problem.
 
  • Like
Reactions: SUMDATX

·
Old Goat
Joined
·
25,398 Posts
Discussion Starter #13
Remove the battery connections, clean posts and cable lugs. Verify fuse on charging cable is good. Also the connector.
....post are kept clean and everything always coated with dielectric grease...there is no fuse on cable...my opinion is the yuasa maintainer is not up to the job...thanks for all the replies...
 
  • Like
Reactions: Harkon and SUMDATX
1 - 13 of 13 Posts
Top