Honda VTX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #1
X'ers,

When I bought the X last summer, I immediately put in a Xenon bulb. I had done this with my Sabre as well. With the Sabre, it one time blew a fuse and the whole light went out. I just replaced the fuse.

Last night, I went to ride home and the high beam blew when I started her up. Low beam still works. I haven't had time to take a good look yet but was wondering if anyone had a similar experience and idea as to what happened.

When I installed, I was careful not to touch the glass. Is there a separate fuse for just high beam? I don't exactly remember the specs of the bulb, but I am sure some would say I need a voltage doohickey. Is it common for either the high or low beams to burn out while the other still works?

Appreciate any help you can give.

Ptackley
 

·
Registered
Joined
·
437 Posts
my stock one is blown out after only about 4k. what a shock when you go to use the high beam on a back road and everything goes out. yikes! i really need to replace that tonite!
 

·
Registered
Joined
·
225 Posts
Discussion Starter #4
Yes it was a shock when it blew! Oh well, sounds like it is to be expected. Thanks guys for your input. Off to go get a new light bulb!

PTackley
 

·
Registered
Joined
·
225 Posts
Discussion Starter #6
Chicago-Spike said:
Go to the Sylvania Silver Star, much better light than the stock(same wattage) 8)
Spike,

Where can you buy this bulb?

Ptackley
 

·
Registered
Joined
·
1,613 Posts
1 - 9 of 9 Posts
Top