Honda VTX Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
701 Posts
Discussion Starter · #1 ·
So I was riding last night and I realized that my brake light is not coming on using the front brake. The rear brake triggers it, but pulling the front does nothing.

Is there an obvious place to start looking for the issue?
 

·
Registered
Joined
·
16,088 Posts
utahguyiam said:
So I was riding last night and I realized that my brake light is not coming on using the front brake. The rear brake triggers it, but pulling the front does nothing.

Is there an obvious place to start looking for the issue?
Check to make sure the wires are connected to the switch at the bars. From there you will have to trace the wiring looking for a break somewhere. A DVOM (Digital Volt Ohm Meter)is very helpful along with a wiring diagram :wink:
 

·
Registered
Joined
·
9,553 Posts
There is a boot under the right side cover with the connections. Check there.
 

·
Registered
Joined
·
4,037 Posts
Did you have the handlebar switch off? If so, may not be installed correct or a dirty/faulty switch?
 

·
Registered
Joined
·
4,037 Posts
Did you have the handlebar switch off? If so, may not be installed correct or a dirty/faulty switch? Try bypassing the switch.
 

·
Registered
Joined
·
1,519 Posts
Check the connections on the switch on the handle bars. Make sure both are plugged in. I inadvertently knocked one off while cleaning my bike & plugged it back in and solved my problem.

I hope it is as easy for your fix as was mine and this is the problem.

Good luck, Jim...
 
1 - 6 of 6 Posts
Top