Honda VTX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
About a month ago I got caught up in a nasty pop-up storm while riding and ever since then my front left turn signal has been permanently on. When I turn the left signal on it flashes normally, but once the turn signal is turned off it goes back to being constantly on?! I've taken the bulb out to make sure it was dry but that didn't help. Any suggestions? Thanks!
 

·
Registered
Joined
·
822 Posts
The front signals stay on with ur headlight while running. use as turn signals the back to running lights
Yep, the front signals stay light when the signals aren't on. The front signals have dual filament bulbs I believe. The one filament stays lit as a running light and switches to the other filament that flashes for the signal. I would be willing to bet the filament for the running light on the right side burnt out. Replace your right front bulb and see if it lights up when you turn the key on :thumbup:
 

·
Registered
Joined
·
6,252 Posts
That means the right turning signal bulb is bad because it is not lit all the time.

Donut
 

·
Registered
Joined
·
27 Posts
Discussion Starter #6
Huh, I've owned this bike for 5 years and never noticed the front turn signals stayed on while riding! :-? It makes sense though. I'll try and replace the right bulb and see if that does the trick. Thanks!
 

·
Registered
Joined
·
6,252 Posts
Huh, I've owned this bike for 5 years and never noticed the front turn signals stayed on while riding! :-? It makes sense though. I'll try and replace the right bulb and see if that does the trick. Thanks!
Yep they are suppose to be on. But not the rear - there amber and it is illegal for them to stay on.
Donut
 

·
Registered
Joined
·
251 Posts
ive got the same problem with my left one too but its my front and rear stay on and wont go away the indicaticator on my dash stays on too but they both still flash when i hit the switch and both shut off the leftside just stays on.

Dude
 

·
Registered
Joined
·
6,252 Posts
ive got the same problem with my left one too but its my front and rear stay on and wont go away the indicaticator on my dash stays on too but they both still flash when i hit the switch and both shut off the leftside just stays on.

Dude
Have you got the bulbs mixed up. the rear only is a single filiment and the front has two filiments.
Two different bulbs on the front bulb and one on the rear.
Rear has one dimple on it on the bottom and front bulb has two. Also the side pins on the front bulbs have alignment posrt on the sides of them so you dont put them in backwards.
 
1 - 9 of 9 Posts
Top