Honda VTX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter · #1 ·
I've had my hyper charger on for almost two years now. I've never had a problem with it until recently. It seems that it hangs wide open all the time while running. Any ideas what may have gone wrong ? I'm thinking the diaphram went bad. I haven't changed anything to make this happen either. If it is the diaphram where should I go for a new one ? Kuryakyn ? Or does someone else have them ? Thanks.
 

·
Registered
Joined
·
363 Posts
Does it work at idle ? Check your vacuum line to make sure it is still good and not leaking kury is the only place i know of to get parts and they may refer you to a dealer not sure
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #3 ·
codi7613 said:
Does it work at idle ? Check your vacuum line to make sure it is still good and not leaking kury is the only place i know of to get parts and they may refer you to a dealer not sure

At idle it is close to 3/4 of the way open.
 

·
Registered
Joined
·
63 Posts
It could be sticking on the filter, they operate pretty close.
 

·
Registered
Joined
·
16,088 Posts
I have seen 1 bad diaphram and 1 diaphram installed backwards from Kury. The easiest way to test is with a vacuum pump :wink: Also check the hose from the intake manifold as I've seen a few damaged from heat and engine cleaners
 

·
Registered
Joined
·
1,427 Posts
could be just warn out. they don't last forever and I have had friends have to replace the diaphram assembly.

it maybe just needs to be lubed with a spray or like said above vacuum leak.

John
 
1 - 6 of 6 Posts
Top