Honda VTX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
the speedo on my 2005 vtx 1800 R not registering speed. performed dign from service manual, wiring checks out and replaced speed sensor. Checked connection at speedo, ok. is there any way to check speedo its self? Anyone have a used working speedo for sale for my 2005 vtx 1800 R.. God Bless, Carlus
 

·
Registered
Joined
·
11,948 Posts
Are the wires on the speed sensor facing down????
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
the speedo on my 2005 vtx 1800 R not registering speed. performed dign from service manual, wiring checks out and replaced speed sensor. Checked connection at speedo, ok. is there any way to check speedo its self? Anyone have a used working speedo for sale for my 2005 vtx 1800 R.. God Bless, Carlus
Yes the wires are pointing down. Is there any test to test the speedo itsself? Does anyone have a used speedo that will work on my 2005 vtx 1800 R. Can mine be repaired. I am frustrated and appreciate any help i can get. God Bless, Carlus
 

·
Registered
Joined
·
11,948 Posts
Did you check to see if you have pulses from the VSS???
Did you open any Green 7 pin connectors that go to the speedo???

The VSS and Speedo unit has its own Ground wire at the "Common Electronics Ground Bolt"
at the front Ignition coil. Green/Black wire.

VSS requires +12v, and a Ground.
With wheel turning (driveshaft connected) it outputs pulses.
Spec is +5v pulses, +3.5 volt pulses are most common.
A digital or analog meter will show the pulses, about 68 - 72 pulses per wheel revolution.

 

·
Registered
Joined
·
26 Posts
When I bought my VTX R it has no working odo and speed.Checked inside and allmost all solders was green.Clean it ,not helped.Bought new and now just fine.But,another day washed the bike and whatte hell!! water tips under the speedo glass.Reassembled it and guess what? No gasket between housing and glass.Nice engineering,very dissapointed.Wonder why they go bad.
 

·
Registered
Joined
·
11,948 Posts
When I bought my VTX R it has no working odo and speed.Checked inside and allmost all solders was green.Clean it ,not helped.Bought new and now just fine.But,another day washed the bike and whatte hell!! water tips under the speedo glass.Reassembled it and guess what? No gasket between housing and glass.Nice engineering,very dissapointed.Wonder why they go bad.
Speedo units rarely go bad. The odometer polarizing filter and the VSS have more failures.
Maybe you are using too much water pressure!
 

·
Registered
Joined
·
26 Posts
Nope,i had the leather tank cover, not heavy washing.And i noticed some months ago early mornig mist under speedo glass but it goes away while i driving about hour or little more.Here in Estonia we have bad skiing weather all the time so to much moisture in open electronics device is not good.No such problem with mine other bikes-VTR1000sp1 &Yamaha GTS
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
the speedo on my 2005 vtx 1800 R not registering speed. performed dign from service manual, wiring checks out and replaced speed sensor. Checked connection at speedo, ok. is there any way to check speedo its self? Anyone have a used working speedo for sale for my 2005 vtx 1800 R.. God Bless, Carlus
After checking eveything in the book and suggested, i took the speedo apart and moved the needle by hand the lubed it with a bit of WD40. The speedo now works, I believe that after sitting a long time the needle was stuck. Thank everyone for their help . God Bless, Carlus
 

·
Registered
Joined
·
11,948 Posts
Another strange malfunction to remember.
One signal to speedo unit feeds two counters, both not indicating suggest lack of signal.
No speedo movement but odometer is good = good VSS.
Speedo needle stuck...
 
1 - 9 of 9 Posts
Top