Honda VTX Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,
just want to say hello. I own a 07 1300r and installed cobra slip ons and have decel backfire. From searching this forum for answers I decided purchase glens perm a/f tool to avoid repeat work. :shock: Kind of worried if the website is still alive and processing orders. If anyone can fill me in that would be great.

Thanks
 

·
Registered
Joined
·
8,458 Posts
Glen is on this site, aka dearsleigher. PM him. Far as I know he's still good in business.
 

·
Registered
Joined
·
3,907 Posts
He is out there give it a little time and PM him he will answer.

Welcome to the VTXOA from the southeast corner of NC.
 

·
Registered
Joined
·
395 Posts
ssmilloy36,

Did you have the decel backfire with the stock exhaust pipes? If yes then your problem may be related more to a vacuum hose or something at the manifold.

However if this is new to that new exhaust system then you must have a gasket or something missing. If you can't find a location/joint where the air is escaping, I would remove the system at least back to the headers and check each joint to see if it has the correct gasket or whatever.

Of course the possibility exists that something else was messed up during the installation. Then I would worry about rejetting/reprogramming after I was sure the system was secure and all vacuum points and hoses were in good shape.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
Glenn is definitely still active. My order came in within a week. I never had backfire before the slip on. Maybe stock was too quiet to notice. the tool so far stopped the back fire during shifting.
when people say 1/4 turn for how many miles is where I'm lost. being at high rpms ie down shifting reduces popping.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #10
I did re install with a self gasket liquid as there was no room for a gasket to fit in the muffler tip. still same outcome. I see the existing gasket in the stock muffler but that's like a billion strands that fall apart
 

·
Registered
Joined
·
553 Posts
I have stock pipes on my used 09 1300 and the baffles were removed by the previous owner, but has always had a little popping when I decelerate, but I live with it.
 
1 - 11 of 11 Posts
Top