Honda VTX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hello. I have a new to me 04 1300c, with 32,000 miles. Had it 3 days and put 150 miles on it. Things I notice: smooth engine, long reach for me to the stock drag bar (will remedy with Genmar risers), and a horribly rough ride. When hitting bumps, the front end feels like an old mini bike with no suspension. Back end is hard, too, but I can/will try a different rear shock setting.
With regard to the front, does that sound like worn out springs? I appreciate your advice.

jeff.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
RE: Suspension

Check the fork oil level....probably a good time to flush it out and change it. You can throw a racetech system in there if you want to break it down further.
Good idea. Thanks!
 

·
Registered
Joined
·
2,181 Posts
Check the fork oil level....probably a good time to flush it out and change it. You can throw a racetech system in there if you want to break it down further.
It might be progressive springs in there.. When I had progressive springs it was very rough. Switched to Racetech and have a very smoothe ride now.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
RE: progressive

It might be progressive springs in there.. When I had progressive springs it was very rough. Switched to Racetech and have a very smoothe ride now.
Whatever it is, it's rough! I think I'll look into the Racetech setup. I don't care to feel every bump. Thanks!
 
1 - 5 of 5 Posts
Top