Honda VTX Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have been searching the forums about my dark odometer. I looks like it should be the polarizing film, i tried to scrape it off, but it seems to be in the lcd itself.

i didnt want to scratch the surface too much if i was on the wrong track.

Also i couldnt get the connectors apart to work on it on my table.

Any suggestions?
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
i read that first. if you notice in one of the pictures i started scraping the lens and nothing changed. it looks like there is a plastic cover over the film. it is a 2005 if that makes any differance.
 

·
Super Moderator
Joined
·
64,223 Posts
That looks a lot like fire damage, or at the very least high heat damage to burn that brown and craze the glass like that. The only thing that will fix that is a new speedo
 

·
Registered
Joined
·
12,964 Posts
JAMMA>>Once I got the film, there was still glue had to be removed. I tried a plastic scraper and finger nails, but a soft rag and iso alcohol did the trick. Took longer to get the glue off than any of the rest of the repair. Couldn't get a clear pic of the glue (like the pic with the film is clear, lol per Jamma

A PDF doc with info.
 

·
Registered
Joined
·
1,117 Posts
Once I got a corner lifted the whole thing came off in two pieces. No glue residue to content with.
Be sure to take the protective film off th film prior to install. Ask me how I know.
 

·
Old Goat
Joined
·
26,225 Posts
Once I got a corner lifted the whole thing came off in two pieces. No glue residue to content with.
Be sure to take the protective film off th film prior to install. Ask me how I know.
How u know…..
 

·
Registered
Joined
·
1,117 Posts
Let’s just say it looks sooo much better with the film off.
 
1 - 9 of 9 Posts
Top