Honda VTX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Wondering if anyone else has had this problem of a cracked lower bracket for the radiator on the VTX1800R. i have a 2006 which i had to replace the radiator last year because of the cracked lower bracket. and now it has happened again...this time used some JB Weld to hold in place. just wondering if anyone else has run into this problem and how it was fixed.

:dontknow:
 

·
Registered
Joined
·
247 Posts
I was actually just looking at mine the other day messing with fender and noticed the radiator was loose on the drivers side, Ill have to look an see if it is where the bracket is, most likely is though.
 

·
Registered
Joined
·
100 Posts
Yes,04" C. Had an after market cover on and thought I may have over tightened the bolt. The "L" bracket has a rivet in the middle of it mounting to thr radiator and then, it looks as if it's just painted over. I ground off the paint on all 4 sides and JB weleded it. It's been holding for a while now, 2 months?? I guess the vibration causes the leak, I asume at the rivet?
 

·
Registered
Joined
·
247 Posts
Ill have to look at mine again, I havent seen any leaking, but i definately dont want to have to get a new radiator 100 miles from no where.
 

·
Registered
Joined
·
346 Posts
yes

Wondering if anyone else has had this problem of a cracked lower bracket for the radiator on the VTX1800R. i have a 2006 which i had to replace the radiator last year because of the cracked lower bracket. and now it has happened again...this time used some JB Weld to hold in place. just wondering if anyone else has run into this problem and how it was fixed.

:dontknow:
Yes I had that happen in 04. took it to a radiator shop and he almost couldn't fix it because of how thin the radiator was. He managed to draw some epoxy into the area that leaked after several failed attempt with the solder. I bought a nea radiator but ran the fixed one three years before changing to the new one. after my 1st ride this year I noticed a leak again. I couldn't be lucky enough for it to be a loose hose....my radiator was leaking from the same exact spot as before. Just replaced it again but fortified the bracket area with JB weld as was done above. Time will tell if it makes any difference...
 
1 - 5 of 5 Posts
Top