Honda VTX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
106 Posts
Discussion Starter #1
My right turn signal does not flash when activated. I have the Kury silver bullets in the rear and the kury turn signal mirrors in the front. When I activate the right turn signal the front works fine but the right rear does not flash it just stays lit solid and it does not work with the brakes either. I do have the run brake flash setup. When I check the input of the run/brake mopdule with a test light the test light flashes but when I check the output withe the test light the test light doesn't blink which makes me think it is a bad module?? Has anyone had this kind of problem or have any ideas to fix it?? Thanx for any input..
 

·
Registered
Joined
·
841 Posts
I have the same set-up, only my signal mirrors are Pro-one. To check out your module, switch the inputs so left to right and right to left. I'm guessing that since you get neither the brake nor the turn signal on the right that it might be a wiring problem or bad right taillight (the brake signal comes from a common input - you'd think that the left wouldn't work if the module is bad.)
 

·
Registered
Joined
·
9,181 Posts
Recheck all your wiring:

http://tech.vtxoa.com/index.php?action= ... artlang=en

And then swap wires to see if the problem can be replicated on the other side of the bike. If you swap the wires and the problem moves then it's a problem with the unit or prior to the unit - if you swap it and the problem stays the same then it's a bad light or wiring after the unit.

Let us know what you find. :wink:
 

·
Registered
Joined
·
106 Posts
Discussion Starter #4
Well I think I narrowed it down to be the rtb module. What is the best one to buy and the cheapest to find it??
 

·
Registered
Joined
·
841 Posts
Do you have the Kury RTB module? If you're sure it's bad, then you should have Kury replace it.
 
1 - 7 of 7 Posts
Top