Honda VTX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
293 Posts
Discussion Starter #1
I finally got my bike back together last night and now I have an electrical problem - no turn signals and rear brake light + the relay pops the fuses.

I have a 03 1800 C, and recently installed kurry rear LED bullets, and front LED turn signal mirrors. I have done the diode fix and replaced the turn signal relay with the Raidiantz universal flasher. That flasher is popping the fuses.

After installing each new set of lights, I tested to make sure everything worked. After running the wiring through the bars, the problem started. I double checked all of the wiring, and everything is properly wired. I disconnected all of the wiring harnesses and only plugged in the front turn signals and the fuse is holding. But when I plug in the brown and red harness, the fuse pops.

I'm sure something is grounding out, but I'm at a loss. Any ideas? Should I start in the turn signal switch box? Could it be the foot brake? Thanks for the help! :)
Mike
 
L

·
Guest
Joined
·
0 Posts
Sled,

I would check the wiring in the handlebars. There is a grey wire that goes from the flasher to the turn signal switch. It is the 12volt feed for the flasher. If it shorts in the bars or the switch housing it will cause the fuses to blow.

Lonewolf
 

·
Registered
Joined
·
293 Posts
Discussion Starter #3
Thanks for the info, I'll check that out. Hopefully, I can get this problem fixed so I can ride this weekend!
I was looking at the wiring schem's and they can be confusing.
 

·
Registered
Joined
·
293 Posts
Discussion Starter #5
Thanks Bare. I used a file to smooth the holes a little and used a grommets (info I got from the Sabre site), but it wouldn't suprise me if the sharp metal cuts through the grommets.
:)
 
1 - 5 of 5 Posts
Top