Honda VTX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
It finally got cold here in SE Louisiana and I'm still having problems with the turn signals. Below 67 degrees F they take about 45 seconds to a minute to start flashing above that temp they come right on. Also, lately the neutral light wont come on and I have to raise the kickstand and hold the clutch in to start it. any ideas what to do here?? I did clean the contacts on the turn signal switch but had to wait until the weather got below 67 degrees.
 

·
Registered
Joined
·
10,792 Posts
Many years ago my Neutral switch became intermittent than stopped working.
I pulled it out, saw that the tip had worn down a bit.
The copper washer was thick, so I sanded it and it is in use after many years and miles.

If you took the TS switch apart then it could be the TS flasher.
OEM lights or leds???
Oxidation on connections can cause a high resistance..
Bulb connections or the socket.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #3
Many years ago my Neutral switch became intermittent than stopped working.
I pulled it out, saw that the tip had worn down a bit.
The copper washer was thick, so I sanded it and it is in use after many years and miles.

If you took the TS switch apart then it could be the TS flasher.
OEM lights or leds???
Oxidation on connections can cause a high resistance..
Bulb connections or the socket.
led lights now but it did the same thing with oem. The washer thing I don't understand.
 

·
Registered
Joined
·
10,792 Posts
1 - 4 of 4 Posts
Top